Bug Tracker

Modify

Ticket #11969 (closed bug: fixed)

Opened 22 months ago

Last modified 22 months ago

Missing null check when gathering siblings

Reported by: dmethvin Owned by: dmethvin
Priority: blocker Milestone: 1.8
Component: selector Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

Ref  http://bugs.jqueryui.com/ticket/8409

Not sure why the null check for cur was removed.

Change History

comment:1 Changed 22 months ago by dmethvin

  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to selector
  • Milestone changed from None to 1.8

Reported by FJ1 in IRC.

comment:2 Changed 22 months ago by timmywil

Looks like this reduction commit removed the null check by accident:  https://github.com/jquery/jquery/commit/df254d47e43e6e1652b20a3b338b26f634cd2b2a#src/traversing.js

comment:3 Changed 22 months ago by dmethvin

  • Owner set to dmethvin
  • Status changed from open to assigned

comment:4 Changed 22 months ago by dmethvin

#11968 is a duplicate of this ticket.

comment:5 Changed 22 months ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #11969. Never a null moment when checking siblings.

Changeset: cde4c326b82af4679026a202f02799e9fbd18cb4

comment:6 Changed 22 months ago by FlashJunior

thank you so much! all my tests are working now!

comment:7 Changed 22 months ago by dmethvin

#12019 is a duplicate of this ticket.

comment:8 Changed 22 months ago by dmethvin

#12053 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.