Bug Tracker

Ticket #11838 (closed bug: duplicate)

Opened 2 years ago

Last modified 2 years ago

Invalid argument in IE8 and earlier versions

Reported by: zbit Owned by: zbit
Priority: low Milestone: None
Component: css Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

Invalid argument in development version at line 8988 and symbol 5.

fx.elem.style[ fx.prop ] = fx.now + fx.unit

Change History

comment:1 Changed 2 years ago by sindresorhus

  • Owner set to zbit
  • Priority changed from undecided to low
  • Status changed from new to pending

Why is it invalid?

comment:2 Changed 2 years ago by zbit

  • Status changed from pending to new

In IE8- doesn't work attribute "background-position", only "background-position-(x/y)" in animate. Corrected by identifying the browser and change the attribute.

Last edited 2 years ago by zbit (previous) (diff)

comment:3 Changed 2 years ago by sindresorhus

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from unfiled to css

comment:4 Changed 2 years ago by sindresorhus

Duplicate of #10796.

comment:5 Changed 2 years ago by anonymous

so how do I fix this ?

comment:6 Changed 2 years ago by rwaldron

It's been fixed. Please see the original that @sindresorhus linked to

comment:7 Changed 2 years ago by anonymous

i added the css.js file, but it doesnt seem to fix the problem, i am not really sure how this fix should be added to the site?

comment:8 follow-up: ↓ 9 Changed 2 years ago by anonymous

Use separate background-position attribute (background-posytion-x and background-position-y) special for IE8-

comment:9 in reply to: ↑ 8 Changed 2 years ago by anonymous

Replying to anonymous:

Use separate background-position attribute (background-posytion-x and background-position-y) special for IE8-

Sorry, background-position-x =)

Note: See TracTickets for help on using tickets.