Bug Tracker

Modify

Ticket #11402 (closed bug: fixed)

Opened 2 years ago

Last modified 17 months ago

evalScript function fails with error error 80020101 in IE

Reported by: HearnMichael Owned by: jaubourg
Priority: low Milestone: 1.8
Component: ajax Version: 1.7.1
Keywords: Cc:
Blocking: Blocked by:

Description

Line # 6433 is cleaning script text before calling globalEval but only cleans the opening "<!--" tag leaving the closing "-->" tag. This causes error "Could not complete the operation due to error 80020101" in IE8 & 9 but works in other non IE browsers.

 http://jsfiddle.net/sdraU/3/

I would suggest cleaning both the opening and closing tag to eliminate the error.

Also see Ticket #10285 http://bugs.jquery.com/ticket/10285

Change History

comment:2 Changed 2 years ago by HearnMichael

Found bug was introduced from this fix http://bugs.jquery.com/ticket/9221

comment:3 Changed 2 years ago by mikesherov

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 follow-up: ↓ 5 Changed 2 years ago by mikesherov

Duplicate of #9221.

comment:5 in reply to: ↑ 4 Changed 2 years ago by anonymous

Replying to mikesherov:

Duplicate of #9221.

This is not a duplicate of 9221... the code change made from 9221 is causing this bug. 9221 only comments out the opening tag but IE throws an error if the opening tag is commented but the closing tag remains. Both the opening tag and the closing tag need to be commented. This is still an issue.

comment:6 Changed 2 years ago by mikesherov

  • Status changed from closed to reopened
  • Resolution duplicate deleted

oops.

comment:7 Changed 2 years ago by dmethvin

  • Priority changed from undecided to low
  • Status changed from reopened to open
  • Component changed from unfiled to ajax
  • Milestone changed from None to 1.8

comment:8 Changed 2 years ago by jaubourg

  • Owner set to jaubourg
  • Status changed from open to assigned

How is this related to ajax? I'll look into this anyway ;)

comment:10 Changed 2 years ago by jaubourg

  • Status changed from assigned to closed
  • Resolution set to duplicate

comment:11 Changed 2 years ago by jaubourg

Duplicate of #10285.

comment:12 Changed 2 years ago by jaubourg

  • Resolution changed from duplicate to fixed

Fixes #11402. domManip now also removes the closing part of HTML comments or CDATA surrounding executed scripts. Unit tests added.

Changeset: a743be19bd3622071c22e9874c92024bc3f5367a

comment:13 in reply to: ↑ 1 Changed 17 months ago by anonymous

I got the same error 80020101 Then while checking the code line by line,i came to know by mistake i added <script<script>(twice,which is unwanted) once is removed these ,error is not coming. so please check all your javascript code ,especially opening tag are closed properly

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.