Bug Tracker

Modify

Ticket #11293 (closed bug: fixed)

Opened 2 years ago

Last modified 23 months ago

Reading width or outerWidth of empty TDs alters columns width values

Reported by: enzole Owned by: mikesherov
Priority: low Milestone: 1.8
Component: dimensions Version: git
Keywords: Cc:
Blocking: Blocked by:

Description

jQuery 1.7.1: Trying to get widths of empty cells produces a scrambled table:

 have a look at this example

This happens only on WebKit browsers (tested on Safari 5.1.2 mac/pc and Chrome 16.0.whatever mac/pc).

Change History

comment:1 Changed 2 years ago by addyosmani

  • Priority changed from undecided to low
  • Status changed from new to open

Weird. What I'm experiencing (even without the last line modifying anything) is a style tag being injected where it shouldn't be (confirmed Chrome Canary):

 http://addyosmani.com/gyazo/7421c2.png

comment:2 Changed 23 months ago by mikesherov

  • Owner set to mikesherov
  • Status changed from open to assigned
  • Version changed from 1.7.1 to git
  • Component changed from unfiled to dimensions
  • Milestone changed from None to 1.8

comment:3 Changed 23 months ago by mikesherov

related to #11696

comment:4 Changed 23 months ago by mikesherov

#11696 is a duplicate of this ticket.

comment:6 Changed 23 months ago by mikesherov

#11522 is a duplicate of this ticket.

comment:7 Changed 23 months ago by Mike Sherov

  • Status changed from assigned to closed
  • Resolution set to fixed

Don't swap to measure dimensions unless the element is display:none. #807 Fixes #11293

Changeset: c80bc227280e9708dc9c3613ece9397f55f382ed

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.