Bug Tracker

Modify

Ticket #10901 (closed enhancement: fixed)

Opened 2 years ago

Last modified 2 years ago

have unit tests fail if the tester is running from file:// or doesn't have PHP

Reported by: mikesherov Owned by: mikesherov
Priority: low Milestone: 1.7.2
Component: build Version: 1.7.1
Keywords: Cc:
Blocking: Blocked by:

Description

currently, the unit tests will silently skip tests that need PHP if not run on a hosted environment. I suspect more than a few testers don't even know this, and so there should be a message letting them know that the only way to run a "full" test is from a hosted environment

Change History

comment:1 Changed 2 years ago by mikesherov

  • Owner set to mikesherov
  • Priority changed from undecided to low
  • Status changed from new to assigned
  • Component changed from unfiled to build
  • Milestone changed from None to 1.7.2

comment:2 Changed 2 years ago by mikesherov

PHP is now a requirement.

comment:3 Changed 2 years ago by mikesherov

#11265 is a duplicate of this ticket.

comment:4 Changed 2 years ago by mikesherov

  • Summary changed from have unit tests alert the tester if they are running from file:// to have unit tests fail if the tester is running from file:// or doesn't have PHP

comment:5 Changed 2 years ago by timmywil

  • Status changed from assigned to closed
  • Resolution set to wontfix

We can continue discussion, but I don't think we're going to do this. It is better to run whatever tests can be run.

comment:6 Changed 2 years ago by rwaldron

I want to put a moratorium on any further changes to the test suite.

comment:7 Changed 2 years ago by Mike Sherov

  • Resolution changed from wontfix to fixed

fixes #10901, PHP required for unit tests, but still allow the tests to run

Changeset: 7226cf2800315e90b671db63f2b5f51150ad7e8e

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.