Bug Tracker

Modify

Ticket #10782 (closed bug: fixed)

Opened 2 years ago

Last modified 23 months ago

Incorrect calculating width

Reported by: anonymous Owned by: mikesherov
Priority: low Milestone: 1.7.2
Component: css Version: 1.7
Keywords: Cc:
Blocking: Blocked by:

Description

If parent is hidden width() represents width in pixels however it's in percent.

 http://jsfiddle.net/CaJNB/

Change History

comment:1 Changed 2 years ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to css
  • Milestone changed from None to 1.next

Confirmed.  http://jsfiddle.net/timmywil/CaJNB/3/

We run into problems when padding and margin do not have the same unit, so perhaps we should normalize to 0 when the unit is not pixels.

comment:2 Changed 2 years ago by timmywil

  • Owner set to timmywil
  • Status changed from open to assigned

comment:3 Changed 2 years ago by mikesherov

@timmywil, #9945 is the same thing essentially, can we tackle both in 1.7.2 please? I'll gladly jump on it.

comment:4 Changed 2 years ago by mikesherov

@timmywil, #10117 too.

comment:5 Changed 2 years ago by timmywil

@mikesherov: feel free to take them on!

comment:6 Changed 2 years ago by dmethvin

#10894 is a duplicate of this ticket.

comment:7 Changed 2 years ago by mikesherov

  • Owner changed from timmywil to mikesherov

comment:8 Changed 2 years ago by timmywil

  • Status changed from assigned to closed
  • Resolution set to fixed

When the width/height computed unit is not pixels, return that instead. Fixes #10782.

comment:9 Changed 2 years ago by timmywil

  • Milestone changed from 1.next to 1.7.2

comment:10 Changed 2 years ago by dmethvin

#11041 is a duplicate of this ticket.

comment:11 Changed 2 years ago by dmethvin

#11051 is a duplicate of this ticket.

comment:12 Changed 23 months ago by anonymous

This is still broken. Both the jsfiddle above (using 1.7.2) and production code still show this problem.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.