Bug Tracker

Modify

Ticket #10299 (closed bug: fixed)

Opened 3 years ago

Last modified 17 months ago

hrefNormalized === false also needs a propHook

Reported by: info@… Owned by: rwaldron
Priority: blocker Milestone: 1.9
Component: attributes Version: 1.6.4rc1
Keywords: ie6 ie7 Cc:
Blocking: Blocked by:

Description

jQuery always normalized the content attribute for href/src in IE6/7. Now we have prop and I think, jQuery should also normalize the href/-src-property.

In IE6/7 getting the href attribute should look like this (is already done by jQuery):

anchor.getAttribute('href', 2);

In IE6/7 getting the href property should look like this (should be done by jQuery):

anchor.getAttribute('href', 4);

I made a jsfiddle to document the problem:

 http://jsfiddle.net/trixta/PH76V/

Please also have a look at the Microsoft documentation of getAttribute:  http://msdn.microsoft.com/en-us/library/ms536429%28VS.85%29.aspx

Change History

comment:1 Changed 3 years ago by rwaldron

  • Owner set to timmywil
  • Status changed from new to assigned
  • Component changed from unfiled to attributes

comment:2 Changed 3 years ago by rwaldron

  • Owner changed from timmywil to rwaldron
  • Priority changed from undecided to low

@timmywil I haven't actually reviewed this issue or the fiddle

comment:3 Changed 2 years ago by dmethvin

  • Milestone changed from None to 1.8

This ticket looks valid to me, seems like we need a propHook here. Given that it's for prehistoric browsers I'd be okay with inferring off the existing hrefNormalized detect rather than adding more code to support.js for it.

comment:4 Changed 22 months ago by dmethvin

  • Keywords ie6 ie7 added

comment:5 Changed 21 months ago by dmethvin

  • Priority changed from low to blocker
  • Milestone changed from 1.8 to 1.8.1

comment:6 Changed 20 months ago by dmethvin

  • Milestone changed from 1.8.1 to 1.9

comment:7 Changed 18 months ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #10299. Add a propHook for oldIE link href.

Changeset: 240b141a22c4783d619fc67c91f990d1535e7c57

comment:8 Changed 17 months ago by timmywil

#12915 is a duplicate of this ticket.

comment:9 Changed 17 months ago by timmywil

  • Status changed from closed to reopened
  • Resolution fixed deleted

The committed solution is invalid. The src and href attributes should return unaltered strings. We use getAttribute( "href", 2) to get the unaltered string. This should not be changed.

See the native behavior in a modern browser for support of what I'm talking about.  http://jsbin.com/alebuq/1/

comment:10 Changed 17 months ago by timmywil

  • Status changed from reopened to closed
  • Resolution set to fixed

Sorry, I have attributes on the mind.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.