Bug Tracker

Modify

Ticket #10006 (closed bug: fixed)

Opened 3 years ago

Last modified 20 months ago

method show is not working as expected in all browsers when called for document fragment

Reported by: markel Owned by: rwaldron
Priority: high Milestone: 1.7.2
Component: effects Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

When html generated from template (or something like that), sometimes need to call method "show" to not attached elements and then append them. In contrast with method "hide", "show" is not working in this case, except for Mozilla all others browsers do not set style attribute.

Of course it's very easy to fix with setting display property manually, but it's not very easy to understand when you have this kind of inconstancy.

test case:  http://jsfiddle.net/CHdWQ/

Change History

comment:1 Changed 3 years ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to effects
  • Milestone changed from None to 1.next

We may be able to just add a check to see if the node is connected.

 Third party pull request

comment:2 Changed 2 years ago by rwaldron

  • Owner set to mikesherov
  • Priority changed from low to high
  • Status changed from open to assigned
  • Milestone changed from 1.next to 1.7.1

comment:3 Changed 2 years ago by rwaldron

#10695 is a duplicate of this ticket.

comment:4 Changed 2 years ago by rwaldron

  • Owner changed from mikesherov to rwaldron

Whoops, didn't mean to assign @mikesherov to this, that was an accident

comment:5 Changed 2 years ago by rwaldron

I cleaned up Orkel's patch and made a fresh PR:  https://github.com/jquery/jquery/pull/581

comment:6 Changed 2 years ago by Rick Waldron

  • Status changed from assigned to closed
  • Resolution set to fixed

Landing pull request 581. Updates original patch by Orkel. Fixes #10006.

More Details:

comment:7 Changed 2 years ago by Dave Methvin

Revert "Landing pull request 581. Updates original patch by Orkel. Fixes #10006."

This reverts commit 299bc655c90cc89652417675f976ae1bfefc4d8b.

Changeset: 3586ea28a8303a8de9f7f94da9fe9c4272b3d8ec

comment:8 Changed 2 years ago by dmethvin

  • Status changed from closed to reopened
  • Resolution fixed deleted

This patch was causing a memory leak only in Testswarm so we backed it out. Yeah, I don't understand it either.

 http://swarm.jquery.org/job/457/

comment:9 Changed 2 years ago by dmethvin

  • Status changed from reopened to open
  • Milestone changed from 1.7.1 to 1.next

comment:10 Changed 2 years ago by dmethvin

  • Milestone changed from 1.next to 1.7.2

comment:11 Changed 2 years ago by Oleg

  • Status changed from open to closed
  • Resolution set to fixed

Fix #10006: Allow .show() to work on detached elements.

Changeset: cc5e8e3866e5dac7eacda5927679573c8da79492

comment:12 Changed 20 months ago by anonymous

It seems like this was added in rather than removed. I'm seeing this bug after having updated to v1.7.2 from v1.4.4, but only in Chrome.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.