Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#9996 closed bug (worksforme)

outerHeight and height() not working Correctly on pressing CTRL + F5

Reported by: mahaidery@… Owned by:
Priority: undecided Milestone: 1.6.3
Component: unfiled Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have been working on a Site where I have a border which needs to be displayed correctly, so I need to get the height of a Inner box and make it round according to the border height!

Here's my Code:

var J=jQuery.noConflict($);
J(document).ready(function () {
var p=J("#inner").outerHeight();
var q=p/151;
var s=Math.ceil(q);
var t=s*151;
var w=t-25;
J('#inner').css({'height':w});
});

P.S: 151 is a height of one Block on Border, This Code works perfectly but When I press the CTRL + F5 the Height not renders Correctly.. Similarly with the Height() function of Jquery.

Change History (3)

comment:1 Changed 8 years ago by mahaidery

Okay, Found the Problem myself, on my page there is an Image which height not calculates when I press the CTRL + F5, now I defined the width and height of that image so the problem is solved..

I hope it will help people like me who have the same problem in different Functions and Plugins of jQuery.

BTW: I guess, in the next versions of jQuery, You guys will take care of it..

comment:2 Changed 8 years ago by Rick Waldron

Milestone: None1.6.3
Resolution: worksforme
Status: newclosed

Closing per OP's comment

comment:3 Changed 6 years ago by anonymous

Hi,

I got the same issue got fixed with the answer. Thanks a Lot

Note: See TracTickets for help on using tickets.