Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#9983 closed bug (duplicate)

clone() of html5 video causes refesh in Safari 5.1

Reported by: brian@… Owned by: rwaldron
Priority: low Milestone:
Component: manipulation Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

When attempting to clone an instance of videoJS and custom player controls the page is refreshed when using Safari 5.1. Other browsers does not produce this effect.

Example here: http://black-tooth.com/sites/lion-video-test/test3.html

Change History (7)

comment:1 Changed 5 years ago by rwaldron

  • Component changed from unfiled to manipulation
  • Milestone changed from None to 1.6.3
  • Owner set to rwaldron
  • Status changed from new to assigned

comment:2 Changed 5 years ago by rwaldron

That's not actually a page refresh, that's how Safari handles a crash.

comment:3 Changed 5 years ago by rwaldron

  • Priority changed from undecided to low
  • Resolution set to worksforme
  • Status changed from assigned to closed

Or not... I'd seen behaviour like that before. Anyway, this is not an issue with jQuery. I'd suggest looking through that mess in video.js

http://jsfiddle.net/rwaldron/wgGq8/

comment:4 Changed 5 years ago by rwaldron

  • Resolution worksforme deleted
  • Status changed from closed to reopened

For kicks, I went back and had another look, just in case - turns out I was right, if you hit clone let it reload, hit it again and repeat this... you will see the error recovery message. The problem seems to stem from cloning elements that have a video INSIDE them, not the video itself.

Version 0, edited 5 years ago by rwaldron (next)

comment:5 Changed 5 years ago by rwaldron

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:6 Changed 5 years ago by rwaldron

Duplicate of #9886.

comment:7 Changed 4 years ago by dmethvin

  • Milestone 1.6.3 deleted
Note: See TracTickets for help on using tickets.