Bug Tracker

Opened 13 years ago

Closed 12 years ago

#996 closed bug (wontfix)

Interface sortable containment:'parent' dragged item not positioned correctly

Reported by: kristian Owned by: stefan
Priority: major Milestone: 1.1.3
Component: interface Version: 1.1.1
Keywords: containment sortable wrong position Cc:
Blocked by: Blocking:

Description (last modified by scott.gonzal)

When the parameter containment:'parent' is set in a sortable, the dragged item jumps to the left of the window. The y-axis seems to be working as required, but the x-coordinate seems to be set to 0.

Change History (3)

comment:1 Changed 13 years ago by mike@…

Line 253 of idrag.js should read: jQuery.iUtil.getPosition(elm.parentNode),

Not: {x:0,y:0},

comment:2 Changed 13 years ago by eric

I can confirm this. This problem effects isortables.js too. Mike's suggested fix seems to work for me.

comment:3 Changed 12 years ago by scott.gonzal

Description: modified (diff)
need: Review
Resolution: wontfix
Status: newclosed

Interface is no longer supported; consider switching to jQuery UI.

Note: See TracTickets for help on using tickets.