Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9949 closed bug (invalid)

expr.replace is not a function

Reported by: boraz Owned by: boraz
Priority: low Milestone: None
Component: manipulation Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

this the line indicated by firebug:

expr = expr.replace(/\=\s*(['"\]]*)\s*\]/g, "='$1']");

here is the code which causes the error, notice that this code have been working untill last friday, i didn't change jquery version, the code got broken with no apparent reason.

here i get two html select and their labels var inStock = $('#selectedStore'); var stockLabel = $(inStock).prev("label"); var inProducer = $('#selectedProducer'); var producerLabel = $(inProducer).prev("label"); here i get the html div which contains the selects and labels var div = $(inStock).parent('div'); here i remove one of the two label/select pair because i need to palce it after the other div.remove(inStock); this line gives error, but it didn't few days ago, it always worked div.remove(stockLabel); here i place the objects after the element i want $(inProducer).after(stockLabel); $(stockLabel).after(inStock);

the code is not working also on chrome and ie.

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledmanipulation
Owner: set to boraz
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.