Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9918 closed bug (duplicate)

if $.data fails if the data has value 0

Reported by: anonymous Owned by:
Priority: low Milestone: None
Component: data Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

Assume thisCache[ jQuery.camelCase( name ) ] returns 0 then the case thisCache[ name ] is evaluated.

This is a problem if 0 should be retrieved.

line 1516

thisCache[ jQuery.camelCase( name ) ]
thisCache[ name ] :

thisCache;

Change History (5)

comment:1 Changed 8 years ago by addyosmani

Component: unfileddata
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:6 Changed 8 years ago by addyosmani

Duplicate of #9917.

comment:7 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: closedreopened

comment:8 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: reopenedclosed

comment:9 Changed 8 years ago by Rick Waldron

Duplicate of #9779.

Note: See TracTickets for help on using tickets.