Bug Tracker

Opened 10 years ago

Closed 9 years ago

#9896 closed bug (invalid)

animate border width with 'toggle' value causes element to dissappear

Reported by: [email protected] Owned by: [email protected]
Priority: high Milestone: 1.next
Component: effects Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

With this code:

<!DOCTYPE HTML> <html> <head> <meta charset="UTF-8"> <title>Untitled Document</title> <style> #test {

width: 50%; background-color: red; border-style: solid; border-color: black; border-width: 50px;

} </style>

<script src="http://code.jquery.com/jquery-latest.js"></script>

<script> $(document).ready(function() {

$('html').click(function() {

$('#test').animate({ borderLeftWidth : 'toggle' });

});

}); </script> </head> <body> <div id="test">blah</div> </body> </html>

On the first click, the left border animates to 0 and then the entire element dissappears. Click again and the element reappears and animates to original 50px value.

Change History (6)

comment:1 Changed 10 years ago by timmywil

Component: unfiledeffects
Owner: set to [email protected]
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/

Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by [email protected]

Status: pendingnew

comment:3 Changed 10 years ago by Rick Waldron

Priority: lowhigh
Status: newopen

Further reduction: http://jsfiddle.net/rwaldron/Z2Xnd/

Confirmed.

comment:4 Changed 10 years ago by Rick Waldron

Milestone: None1.next

comment:5 Changed 10 years ago by gnarf

This works as intended: http://jsfiddle.net/Z2Xnd/1/ the toggle value will call show/hide at the beginning/end of its animation... It is still animating.

comment:6 Changed 9 years ago by dmethvin

Resolution: invalid
Status: openclosed
Note: See TracTickets for help on using tickets.