Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9888 closed bug (invalid)

weird behaviour of selector in IE and Chrome

Reported by: anoopsharma@… Owned by: anoopsharma@…
Priority: low Milestone: None
Component: selector Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

IE and Chrome Converts all element having ID into variable [Object Type] .

A sample Example is as follows:

<html><head> <script src="jquery-1.6.2.min.js"></script> <script> $(function(){ alert(typeof abc);returns undefined in firefox and object in IE and Chrome :(

}); </script> </head> <body>

<input id="abc" value="abca"> </body> </html>

Please let me know ASAP.

Regards, Anoop Sharma 09289988071 QAInfoTech

Change History (4)

comment:1 Changed 8 years ago by timmywil

Component: unfiledselector
Owner: set to anoopsharma@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 8 years ago by anonymous

In IE and Chrome Every element is available as a variable(named as its ID). Its A major issue.

comment:4 Changed 8 years ago by dmethvin

This is not a jQuery problem, nor is it anything jQuery can control.

Note: See TracTickets for help on using tickets.