Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9878 closed bug (duplicate)

IE needs catch() before finally

Reported by: scraze@… Owned by: jaubourg
Priority: high Milestone: None
Component: ajax Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Tested with IE8.0 on Windows Vista Home Premium: IE gives a warning ("Invalid argument") when it runs into 'finally' on line 998, in the try starting on line 993. According to random google result "http://webbugtrack.blogspot.com/2007/11/bug-184-catch-to-try-catch-finally-in.html", finally isn't even executed without catch. Either way, an empty catch such as on line 4894 ("catch(pseudoError) {}") resolves the issue. (Thanks!)

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Owner: set to scraze@…
Status: newpending

comment:2 in reply to:  1 Changed 8 years ago by scraze@…

Status: pendingnew

Replying to rwaldron:

Are you actually referring to this:

https://github.com/jquery/jquery/blob/master/src/deferred.js#L61-62

Indeed I'm referring to the highlighted lines - I failed to mention it's in the function resolveWith.

comment:3 Changed 8 years ago by Rick Waldron

Component: unfiledajax
Owner: changed from scraze@… to jaubourg
Priority: undecidedhigh
Status: newassigned

Thanks!

comment:4 Changed 8 years ago by jaubourg

Resolution: duplicate
Status: assignedclosed

comment:5 Changed 8 years ago by jaubourg

Duplicate of #9033.

Note: See TracTickets for help on using tickets.