Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9859 closed bug (invalid)

Event remove attribute disabled issue

Reported by: aphonso@… Owned by: aphonso@…
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

In the following code:

... <script type="text/javascript">

$(document).ready(function() {

$('#engines_combo').change(function() { alert($('#engine_values').attr('disabled')); $('#engine_values').removeAttr('disabled'); alert($('#engine_values').attr('disabled')); });

});

</script>

...

<select id="engines_combo" class="element_select">

<option>Engine 1</option> <option>Engine 2</option>

</select>

<fieldset id="engine_values" disabled="disabled" style="100%">

<legend>Engine Values</legend>

<div style="width: 900px;">Test removing disabled attribute</div>

</fieldset>

The childs elements of engine_values, should be enabled after changing the the combo engine.

In previous version the change works perfectly.

Thank you in advanced.

Best regards.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledattributes
Owner: set to aphonso@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 8 years ago by dmethvin

$('#engine_values').removeAttr('disabled')

Use this instead: $('#engine_values').prop('disabled', false)

Note: See TracTickets for help on using tickets.