Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9853 closed bug (duplicate)

browser throws 'not a function' after abort a jsonp request

Reported by: henrypares@… Owned by:
Priority: low Milestone: None
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

i use ajax with jsonp type , i call abort() when it does not return , and jsonp callback will be removed from window , so that when the request returns , the browser will throw 'jqueryxxxx is not a function' exception.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledajax
Milestone: 1.nextNone
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #8744.

comment:3 Changed 8 years ago by anonymous

I think I'm experiencing the same, or at least a similar, issue. I have a function that makes an ajax call when a dialog is opened and I have that function aborted when the dialog is closed. That works fine, however I'm unable to recall the function, receiving an error that it is no longer a function.

Note: See TracTickets for help on using tickets.