Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9829 closed bug (invalid)

Status ok for aborted HTTP session when using ajax

Reported by: rumax Owned by: rumax
Priority: low Milestone: None
Component: ajax Version: 1.6.2
Keywords: Cc: jaubourg
Blocked by: Blocking:

Description

  1. Make a request to some resourse
  2. Using Fiddler break session before request
  3. Using Fiddler abort session
  4. Some new request are send to server - OK. All this requests are aborted too
  5. Get called success call back function. Expected - error callback function to be called

Change History (6)

comment:1 Changed 8 years ago by rumax

Firefox 5.0 Used. In IE - only 1 request

comment:2 Changed 8 years ago by timmywil

Component: unfiledajax
Owner: set to rumax
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:3 in reply to:  2 Changed 8 years ago by anonymous

Replying to timmywil:

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

$.ajaxSetup({
    url: url,
    type: "POST",
    cache: false,
    error: function (jqXHR, textStatus, errorThrown) {
        _HttpLayer_callBack_Error(jqXHR, textStatus, errorThrown);
    },
    success: function (data, textStatus, jqXHR) {
        _HttpLayer_callBack(data, textStatus, jqXHR);
    }
});

$.ajax({
  data: "action=disconnect"
});

comment:4 Changed 8 years ago by anonymous

Strange. Looks like I cannot reproduce it again (after PC reboot). Will provide more details if get the problem again.

comment:5 Changed 8 years ago by jaubourg

Resolution: invalid
Status: pendingclosed

OK, so I'll close this as invalid for now. Just comment in here to ping us if you are finally able to reproduce the issue consistently.

comment:6 Changed 8 years ago by jaubourg

Cc: jaubourg added
Note: See TracTickets for help on using tickets.