Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9783 closed bug (invalid)

Getting dimensions of a cached picture

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: css Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

When you load a cached picture (let says 50x50px) by: j('<img/>').load(function(){ alert(j(this).width()+' px : '+j(this).css('width')+' px'); }).attr({src:pathToPicture});

It returns: jquery1.5.2 -> 50 px : 50 px jquery1.6.2 -> 0 px : undefined px

Change History (5)

comment:1 Changed 8 years ago by timmywil

Component: unfiledcss
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by anonymous

Status: pendingnew

I suggest to change the priority to high. All my image loadings does not work for example.

About a test case with jsfiddle.net, jquery 1.6.2 is not provided (on July the 8th, 2011).

comment:3 Changed 8 years ago by timmywil

Status: newpending

Click the fork button. jQuery(edge) is the version that should be used for test cases.

http://jsfiddle.net/timmywil/jZmMq/

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 8 years ago by anonymous

See it in action:

http://jsfiddle.net/ycKPP/

Switch jquery version from 1.6.2 to 1.5.2 and see results.

Note: See TracTickets for help on using tickets.