Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9774 closed bug (wontfix)

.promise() after animation not returned properly (working in 1.6.1)

Reported by: [email protected] Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.6.2
Keywords: neededdocs Cc:
Blocked by: Blocking:

Description

If there are some nested animations, the promise is not being properly returned, so the .done() action is never executed. I attach some jsfiddle code.

If you change de version to 1.6.1 you will properly see the .done() being executed.

http://jsfiddle.net/EgMqN/2/

Thanks for your time :)

Change History (7)

comment:1 Changed 10 years ago by timmywil

Component: unfiledeffects
Priority: undecidedlow
Status: newopen

Confirmed. I would expect the done to be executed at least after the first animation, although the mixture of passing callbacks and using deferreds is odd to me.

http://jsfiddle.net/timmywil/EgMqN/3/

comment:2 Changed 10 years ago by [email protected]

timmy,

actually i found out that the problem is caused by the $(this).remove(). I guess that the promise is destroyed in the .remove() action.

http://jsfiddle.net/EgMqN/6/

comment:3 Changed 10 years ago by timmywil

Keywords: needsdocs added
Resolution: wontfix
Status: openclosed

Oh, that makes sense. Sorry I missed it. The data for the promise needs to be on the element so I don't think we can fix this, but it might be something we want to document.

comment:4 Changed 10 years ago by [email protected]

Mmm, then the bug was in jQuery 1.6.1? I think we might still consider it a bug as it was something that (in my humble opinion) was working in the previous version and none of the 1.6.2 changes should have broken it.

Either way, im going to put the remove() in the deferred callback, not in the animation one as i guess it's the proper way to do it.

comment:5 Changed 10 years ago by timmywil

This is the commit that caused the change in behavior: 3486365062cdc7e8598cea238e67aafa33af7dce

The remove is completed before the deferred is dequeued. I imagine this may work differently once jQuery.Callbacks is introduced in 1.7.

comment:6 Changed 10 years ago by addyosmani

Keywords: neededdocs added; needsdocs removed

docs updated for deferred.promise to reflect the above.

comment:7 Changed 10 years ago by gnarf

I almost feel that removing the element before its animation promises can resolve should probably reject the promise instead of resolve it, but thats just a random thought.

Note: See TracTickets for help on using tickets.