Bug Tracker

Opened 7 years ago

Closed 7 years ago

#9746 closed bug (invalid)

domManip incorrectly adds "?_=NNNN" to passed <script>s

Reported by: andrew@… Owned by:
Priority: low Milestone: 1.next
Component: ajax Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Tested in Firefox 5 on Linux with jQuery 1.6.1.

Steps to reproduce:

  1. Run the following code (e.g. in the Firebug command-line):

$(document.body).append( "<script src='foo.js'></script>" );

  1. Observe the URL that was loaded.
    Observed: .../foo.js?_=1309887155209
    Expected: .../foo.js

Explanation: domManip() calls evalScript(), which in turns calls $.ajax() without specifying "cache: true". $.ajax() adds a parameter to the script elements to force it not to be cached.

A patch is available here: https://github.com/jquery/jquery/pull/429

Change History (1)

comment:1 Changed 7 years ago by timmywil

Component: unfiledajax
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Thanks for taking the time to contribute to the jQuery project! This is intended behavior.

Note: See TracTickets for help on using tickets.