Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9741 closed bug (invalid)

Problems with AJAX loaded checkboxes, using $("input:checkbox").live("click", fn);

Reported by: khaiknievel@… Owned by: khaiknievel@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

There is a problem with AJAX loaded checkboxes. And when I'm bind them with .live(), the tick wont appear. Even if I force checked using .attr() within the bind, it will disappear.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledajax
Owner: set to khaiknievel@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by Rick Waldron

This test case shows a checkbox being added with a click event triggered and no issues

http://jsfiddle.net/rwaldron/9HrLK/

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.