Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9737 closed bug (invalid)

How to receive the response correctly

Reported by: yogachandran.ravindran@… Owned by: yogachandran.ravindran@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

my jquery function executes before the response is received. This is the code: $.post("userOperations?operation=2&userPin="+userIdSelected+"&email="+tEmail+"&oldemail="+useremail+"&password="+password,function(response){

$.trim(response); var myObject = eval('(' + response + ')');-->Here i am getting document as response while i am getting proper response from my back end.

}

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledajax
Owner: set to yogachandran.ravindran@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net (where you can mock ajax requests) or a reduced test case one your own server that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge/git) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.