Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9725 closed bug (worksforme)

Undefined response with multiple find()s on the same object

Reported by: garytalmes@… Owned by: garytalmes@…
Priority: low Milestone: 1.next
Component: attributes Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

I'm using jQuery 1.6.1 (minified) on Firefox 4 (Mac, Snow Leopard).

Say I do this:

$("#mydiv").find("ul.firstlist li a.current").attr("myname");

This yields the expected result.

But now on the next line I do this:

$("#mydiv").find("ul.secondlist li a.current").attr("myname");

This yields "undefined" every time, even though the html is correct and the values are there. It seems that performing a second find() on the same object does not work. And it's not just with attribute calls. I tried applying CSS and that did not work. I also tried to see if I was able to reference $("#mydiv") at all, and I could not.

Workaround: prior to the first find() I make a copy of $("#mydiv") and then perform the second find() on the copy.

Change History (3)

comment:1 Changed 8 years ago by ajpiano

Owner: set to garytalmes@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket! Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, we've created this boilerplate: http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:2 Changed 8 years ago by Rick Waldron

Component: unfiledattributes
Priority: undecidedlow
Resolution: worksforme
Status: pendingclosed

comment:3 Changed 8 years ago by dmethvin

Closer to the description, but yeah it works for me too:

http://jsfiddle.net/dmethvin/bwUFD/1/

garytalmes, this is why a test case is so important. Now two people have taken the time to reproduce the problem and failed.

Note: See TracTickets for help on using tickets.