Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#9716 closed bug (invalid)

Uncaught TypeError: Cannot read property 'length' of undefined :: jquery.js:613

Reported by: lggarrison@… Owned by: lggarrison@…
Priority: low Milestone: 1.next
Component: misc Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

The code breaks if object is undefined and therefore doesn't have a property of length.

Change History (4)

comment:1 Changed 7 years ago by timmywil

Component: unfiledmisc
Owner: set to lggarrison@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 7 years ago by anonymous

Getting the same problem

comment:3 Changed 7 years ago by timmywil

@anonymouse: that error is probably due to a mistake by the user. I suggest http://fixingthesejquery.com

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.