Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9697 closed bug (invalid)

Problem with "td:even or td:odd" when used colspan in a previous line

Reported by: dyego.ti@… Owned by: dyego.ti@…
Priority: low Milestone: 1.next
Component: selector Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, I have the following example code: <table class="tableConsulta">

<tbody>

<tr>

<td colspan="4">

&nbsp;

</td>

</tr> <tr> <td>Name:</asp:Label> </td> <td>

<input type="text" id="txtName" />

</td> <td>

Adress:

</td> <td>

<input type="text" id="txtAddress" /> </td>

</tr>

<tr> <td>

Label:

</td> <td>

<input type="text" id="txtField" />

</td> <td>

&nbsp;

</td> <td>

&nbsp;</td>

</tr> </tbody> <tfoot>

<tr>

<td colspan="4" style="text-align:center">

Footer!!!

</td>

</tr>

</tfoot>

</table>

And Jscript: $(document).ready(function () {

$('.tableConsulta tbody tr td:even').addClass('tdLabels'); $('.tableConsulta tbody tr td:odd').addClass('tdCampos'); $('.tableConsulta thead th').addClass('tdTitulo'); $('.tableConsulta tfoot tr td:even').addClass('tdFootImpar'); $('.tableConsulta tfoot tr td:odd').addClass('tdFootPar');

}); This code above not works correctly if I use colspan. But, if I remove the colspan code, my code runs correctly.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledselector
Owner: set to dyego.ti@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 8 years ago by anonymous

Anybody?

Note: See TracTickets for help on using tickets.