Bug Tracker

Opened 10 years ago

Closed 10 years ago

#9696 closed bug (worksforme)

requestAnimationFrame throws error in Firefox when animation is running while page gets unloaded

Reported by: [email protected] Owned by: [email protected]
Priority: low Milestone: 1.next
Component: effects Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

firefox will throw: "attempt to run compile-and-go script on a cleared scope" in case an animation (i.e. slideDown) is currently running while leaving/reloading the page. In jquery.1.6.1.js (Line 8359 "if ( timerId ) {"

for now I worked around by simply disabling animationFrame support. Tested in Firefox 4.0/OSX.6.8 & FF 5.0/Win7(64bit)

BR Michael

Change History (6)

comment:1 Changed 10 years ago by timmywil

Component: unfiledeffects
Owner: set to [email protected]
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project!

I created a test case, but was not able to reproduce the error in FF5: http://jsfiddle.net/timmywil/dRmgx/

Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 10 years ago by [email protected]

Status: pendingnew

Unfortunately I was unable to reproduce it on jsFiddle (btw. copy/paste would be great there ) but I uploaded a quick 'n simple demo to my dropbox account.

You can grap the 7z archive containing the html and jquery.1.6.1.js file here: http://dl.dropbox.com/u/2358082/bug-demo.7z

The demo in test.html will automatically reload the page while the animation is running so that the error will be thrown. (attempt to run compile-and-go script on a cleared scope) Hope it helps.

comment:3 in reply to:  2 Changed 10 years ago by [email protected]

OK, now I got it working on jsFiddle: http://jsfiddle.net/q9rNp/

comment:4 Changed 10 years ago by anonymous

Looks like it's only affecting FF4, not FF5.

comment:5 Changed 10 years ago by timmywil

I'm not seeing errors in FF4 or FF5. Updated the fiddle to jQuery git:

http://jsfiddle.net/timmywil/q9rNp/2/

comment:6 Changed 10 years ago by addyosmani

Resolution: worksforme
Status: newclosed

Tested across Firefox 4.0 and 5.0 and as per timmywil was unable to reproduce this issue. If you are able to supply additional test cases that we are able to confirm/reproduce we'll be happy to reinvestigate this issue further.

Note: See TracTickets for help on using tickets.