Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9694 closed bug (invalid)

IE9 issue with .animate()

Reported by: dmeagor Owned by: dmeagor
Priority: low Milestone: 1.next
Component: effects Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Effects all versions of JQuery i have tested up to 1.6.1

When animating the width of an IMG (and I believe DIV's too) with some text next to it at slow speeds causes it to overlap adjacent text on IE9 (fine on all other browsers.) Randomly clicking about the page then causes it to reappear in the correct location.

Example

<img src="graph.gif" id="res" class="result" style="width:0%;" /><span>0%</span>

$("#res").animate({width: 80%},2000,"swing");

using something like $("#res").animate({width: 80%}); appears to work as I'm guessing there is an incremental error with each animation step.

Change History (6)

comment:1 Changed 8 years ago by anonymous

comment:2 Changed 8 years ago by David Meagor <david@…>

sorry that bug has been corrected on the link I sent over as it's our production server and i couldn't leave it broken.

We solved the issue by changing the animation speed from 2000 to 1000 which appears to work in all browsers.

comment:3 Changed 8 years ago by timmywil

Component: unfiledeffects
Owner: set to dmeagor
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:4 Changed 8 years ago by dmeagor@…

Very simple one line example here. I would suggest that this is actually quite a high priority bug.

http://jsfiddle.net/K8W3W/4/

comment:5 Changed 8 years ago by anonymous

Very simple one line example here. I would suggest that this is actually quite a high priority bug.

jsfiddle.net/K8W3W/4/

Note your bug reporting system seems to be rejecting anything with a link in it.

comment:6 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.