Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9637 closed bug (duplicate)

$('[data-remote]').live doesn't work in Opera if data-remote attribute has no value

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: 1.next
Component: selector Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Reproduction steps:

Open any page with jQuery in any version of Opera.

Type in console:

document.body.innerHTML = "<span data-remote='true'>first</span><span data-remote>second</span>";
$('[data-remote]').click(function() { console.log('bind ' + this.innerHTML) });
$('[data-remote]').live('click', function() { console.log('live ' + this.innerHTML) });
$('span').trigger('click');

You see in console:

bind first
live first
bind second

You should see in console:

bind first
live first
bind second
live second

Change History (8)

comment:1 Changed 10 years ago by Rick Waldron

Component: unfiledselector
Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, I've created this boilerplate: http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:2 Changed 10 years ago by anonymous

Thank you for answer. Reduced jsFiddle test case: http://jsfiddle.net/morr/uVfRd/

comment:3 Changed 10 years ago by morr <[email protected]…>

I added info and description http://jsfiddle.net/morr/uVfRd/6/

comment:4 Changed 10 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 10 years ago by morr <[email protected]…>

hmmm i added jsFiddle test case and this bug wasn't fixed i suppose you should reopen this ticket

comment:6 Changed 10 years ago by ajpiano

Resolution: invalid
Status: closedreopened

comment:7 Changed 10 years ago by john

Resolution: duplicate
Status: reopenedclosed

comment:8 Changed 10 years ago by john

Duplicate of #5637.

Note: See TracTickets for help on using tickets.