Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9623 closed bug (duplicate)

IE6 & 7 will not match attribute selector queries if the attribute in question has no value or a falsy value.

Reported by: barney.carroll@… Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

IE6 & 7 will not match attribute selector queries if the attribute in question has no value or a falsy value.

Example: http://jsfiddle.net/barney/Qj5Jd/

Change History (3)

comment:1 Changed 8 years ago by anonymous

The test case I provided implies this only concerns custom attributes, however valid markup scenarios (ie images with empty alt attributes) also fail to match

comment:2 Changed 8 years ago by timmywil

Component: unfiledselector
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by timmywil

Duplicate of #7128.

Note: See TracTickets for help on using tickets.