Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9610 closed bug (duplicate)

changed language protocol?

Reported by: IQX99 Owned by:
Priority: low Milestone: 1.next
Component: support Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Win7, IE9

Previous legacy code: "if(elem.getElementsByTagName){...}" but this failed in IE9. Firefox, safari and chrome all ok.

changed to "if(typeof(elem.getElementsByTagName)=='function'){...}" works fine.

Has something changed with the way the if() checks for a return value?

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledsupport
Priority: undecidedlow
Resolution: invalid
Status: newclosed

This code:

if(elem.getElementsByTagName) 

// or... 

if ( elem.getElementsByTagName )

Does not exist in jQuery.

comment:2 in reply to:  1 Changed 8 years ago by anonymous

Please see jquery-1.6.1.js, line 5975

Best regards,

Replying to rwaldron:

This code:

if(elem.getElementsByTagName) 

// or... 

if ( elem.getElementsByTagName )

Does not exist in jQuery.

comment:3 Changed 8 years ago by timmywil

Resolution: invalid
Status: closedreopened

It used to, but has since been changed.

comment:4 Changed 8 years ago by timmywil

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by timmywil

Duplicate of #9370.

Note: See TracTickets for help on using tickets.