Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9582 closed bug (worksforme)

ValueError: invalid literal for int() with base 10: 'mozilla.org/file/local;1'

Reported by: anonymous Owned by: jdsharp
Priority: undecided Milestone: 1.next
Component: web Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a GET operation on /wiki/WikiStart, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'page': u'WikiStart', 'version': u'mozilla.org/file/local;1'}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/wiki/web_ui.py", line 118, in process_request
    versioned_page = WikiPage(self.env, pagename, version=version)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/wiki/model.py", line 40, in __init__
    version = int(version) # must be a number or None
ValueError: invalid literal for int() with base 10: 'mozilla.org/file/local;1'

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledweb
Owner: set to jdsharp

I think I saw this on the bug trac yesterday as well...

comment:2 Changed 8 years ago by addyosmani

#9584 is a duplicate of this ticket.

comment:3 Changed 8 years ago by addyosmani

#9583 is a duplicate of this ticket.

comment:4 Changed 8 years ago by addyosmani

Status: newopen

comment:5 Changed 8 years ago by ajpiano

Resolution: worksforme
Status: openclosed
Note: See TracTickets for help on using tickets.