Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9558 closed bug (invalid)

1.6.1 Getting the value of unexisting attribute is causing - ... is not defined

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.next
Component: attributes Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Example:

$(document).ready(function(){
  $("a").each(function(){
    var rel = $(this).attr("rel");
    if(rel=="Some String"){
      /* if the rel attribute doesn't exists, it's causing an error */
    } 
  });
});

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledattributes
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery Project!. I've recreated your test case here: http://jsfiddle.net/addyosmani/VeAVb/, but haven't been able to reproduce the issue you're experiencing. Could you confirm which browser/version/platform you're seeing it on?

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.