Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9557 closed bug (invalid)

jquery-min.js does not work when online with t-mobile (germany)

Reported by: daniel.aigner@… Owned by:
Priority: low Milestone: 1.next
Component: misc Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

T-Mobile seems to compress files on the fly when surfing on a mobile phone. This compression causes the jquery-1.6.1.min.js (and some older versions also) not to work, javascript error. The normal, uncompressed Version does work without problems. This is a big problem, since t-mobile is the biggest provider in germany.

Change History (5)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledmisc
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Thanks for submitting a ticket to the jQuery Project!. Unfortunately, we are unable to assist with this issue as you will need to speak to T-Mobile directly about their process of compressing any files/jQuery on the fly. We're not directly responsible or able to assist with this, but their development team will probably be interested in resolving this from their end.

comment:2 Changed 8 years ago by addyosmani

#10037 is a duplicate of this ticket.

comment:3 Changed 8 years ago by groves@…

Can verify that this is still an issue with 1.6.2, iOS 5, and T-Modile Germany.

comment:4 Changed 8 years ago by groves@…

Possible fix: using the CDN hosted version doesn't cause this problem:

http://docs.jquery.com/Downloading_jQuery#CDN_Hosted_jQuery

comment:5 Changed 8 years ago by anonymous

Our solution is loading the script via https (as Stan Stare share wrote in #10037). This way the script wont get touched (and compromised) by the mobile phone provider.

Note: See TracTickets for help on using tickets.