Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9529 closed bug (invalid)

Selector not working goed with table's

Reported by: stijn.haulotte@… Owned by: stijn.haulotte@…
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

<?
include_once "../../instellingen.inc.php";

echo Site::boven("Nieuw Topic");
?>
<script type="text/javascript">
$('#aanmaak').click(function(){
		$.post('leden/forum/nieuwValidate.php?wat=aanmaak', $("#testform").serialize(), function(data){
			$('#result').html(data);
		});
	});
</script>
<div id='result'></div>

<form method='post' id='testform'>
*/*<table>
<?
if(!isset($_GET['catid'])){
	echo "<tr><td>Categorie</td><td><select id='select'>";
	$forum = new Forum();
	$cats = $forum->getCategorien();
	$count1 = count($cats);
	for ($i = 0; $i < $count1; $i++) {
		echo "<optgroup label='".$cats[$i][1]."'>";	
		$cats2 = $forum->getSubCategorien($cats[$i][0]);
		$count2 = count($cats2);
		for ($ii = 0; $ii < $count2; $ii++) {
			echo '<option value="'.$cats2[$ii][0].'">'.$cats2[$ii][1].'</option>';
		}
		echo '</optgroup>';
	}
	echo "</select></td></tr>";
}
?>
<tr><td>Titel:</td><td><input type='text' name='titel'></td></tr>
<tr><td colspan='2'><?=Site::editor()?></td></tr>
*/*</table>
<?
echo Site::balkOnder("<input type='button' id='aanmaak' value='Post' name='aanmaak' />");
?></form><?
echo Site::onder();
?>

deze code werkt goed maar als je de 2 lijnen met */* er uit laat niet meer. maar mijn functie boven begint al een tabel {{{public static function boven($tekst, $color=0, $border=0){

$table = "<table id='boven' style='width:100%; position:relative;'"; if($border != '0'){

$table .= "border='".$border."'";

} if($color != '0'){

$table .= "background-color='".$color."'";

}

return $table.'><tr><td colspan="20" valign="top" class="menu"><h1>'.ucfirst($tekst).'</h1></td></tr> <tr><td colspan="20">';

} onderste van een tabel te tonen public static function onder(){

return "</td></tr>

</table>";

}}}}

Change History (2)

comment:1 Changed 8 years ago by ajpiano

Owner: set to stijn.haulotte@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket. If you can provide a summary of the bug in English and what you expect the behaviour to be, that would certainly help as well.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.