Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9528 closed bug (invalid)

KeyError: 'captcha_redirect'

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: 1.next
Component: web Version:
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'445375a67e1a31491c0546bd',
 'recaptcha_challenge_field': u'03AHJ_Vuv4Afy_voyX7-nQf3pvbvygL0Mu5TuulNMJwS0__4xMncR_hjx7eguqpaZIb_mB6ezIg6-9PW0oH9zDg1FEmb8mHMEATOiTfzmkoA2uEoe-mnZ93a7OPjfQhuLWx7QIrQxsfEfsDItDuOVkiVXwgyPuP6UwEQ',
 'recaptcha_response_field': u'Korevaar offorly'}

User agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E)

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (3)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledweb
Owner: set to danheberden
Status: newassigned

comment:2 Changed 8 years ago by danheberden

Owner: changed from danheberden to anonymous
Status: assignedpending

I cannot reproduce this problem when using the bug submission form. Can you please provide additional details as to what prompted the error?

Last edited 8 years ago by danheberden (previous) (diff)

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.