Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9509 closed bug (invalid)

CSS extremely slow in IE9

Reported by: artur.herczeg@… Owned by: artur.herczeg@…
Priority: low Milestone: 1.next
Component: css Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

The following function is extremely slow in IE9 compared to IE7 and IE8. All the dependent functions are slow as well.

css: function( elem, name, extra ) {
                // Make sure that we're working with the right name
                var ret, origName = jQuery.camelCase( name ),
                        hooks = jQuery.cssHooks[ origName ];

                name = jQuery.cssProps[ origName ] || origName;

                // If a hook was provided get the computed value from there
                if ( hooks && "get" in hooks && (ret = hooks.get( elem, true, extra )) !== undefined ) {
                        return ret;

                // Otherwise, if a way to get the computed value exists, use that
                } else if ( curCSS ) {
                        return curCSS( elem, name, origName );
                }
        }

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledcss
Owner: set to artur.herczeg@…
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery Project!. Do you have any tests or performance measurements you can share which confirm how slow you're finding css()?.

If not and this is a generic observation, it would be useful to see a test case (ideally on http://jsfiddle.net) that we can use to evaluate whether we can reproduce the same performance issues you're experiencing.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.