Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9496 closed bug (duplicate)

Non-inline styles fail when appending multiple made-up elements in IE < 9

Reported by: cowboy Owned by: rwaldron
Priority: high Milestone: 1.next
Component: manipulation Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Change History (9)

comment:1 Changed 6 years ago by cmcnulty

IE 8 inserts into the dom with a colon for some reason. See this MSDN article.

You can sorta fix it in IE8 by changing the class definition in css: see here, but that seems to cause other issues.

comment:2 Changed 6 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from new to assigned

comment:3 Changed 6 years ago by cowboy

I'm not sure if this is the issue, but when a made-up node is cloned in POJ it also fails in IE < 9: http://jsfiddle.net/cowboy/g2WVn/

comment:4 Changed 6 years ago by cowboy

  • Description modified (diff)

comment:5 Changed 6 years ago by timmywil

  • Component changed from unfiled to manipulation
  • Priority changed from undecided to high

comment:6 Changed 6 years ago by john

  • Resolution set to invalid
  • Status changed from assigned to closed

Yeah, you should be using the techniques outlined by Rick.

comment:7 Changed 6 years ago by john

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:8 Changed 6 years ago by john

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:9 Changed 6 years ago by john

Duplicate of #6485.

Note: See TracTickets for help on using tickets.