Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9487 closed bug (duplicate)

Calling data on a jQuery object with HTML5 data attributes has strange behavior if attribute names contain singular letters.

Reported by: vincetg2@… Owned by:
Priority: low Milestone: 1.next
Component: data Version: 1.6
Keywords: Cc:
Blocked by: Blocking:

Description

Test case: http://jsfiddle.net/BRv6U/6/

If any of the data attributes have single letters in the middle of the hyphen-separated name they are missing from the returned object of data attributes.

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfileddata
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by timmywil

Duplicate of #9318.

Note: See TracTickets for help on using tickets.