Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9474 closed bug (duplicate)

Calling .stop() in callback freezes animation

Reported by: rtempchin@… Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Animate an element using .animate() and give it a callback. In the callback function, call .stop(). The element will no longer animate in response to .animate() calls.

Test case: http://jsfiddle.net/rtempchin/tCWVH/

Also note that if you move .stop() out of the callback, the element will respond to future .animate() calls but will still ignore one immediately after .stop().

Test case: http://jsfiddle.net/rtempchin/tCWVH/3/

Tested with jQuery 1.6 and 1.6.1 in Chrome (11.0.696.71) for Mac.

Change History (4)

comment:1 Changed 8 years ago by timmywil

Component: unfiledeffects
Priority: undecidedlow
Status: newopen

Confirmed. Not sure what's going on with this one. Some weirdness with the timers. http://jsfiddle.net/timmywil/tCWVH/7/

comment:2 Changed 8 years ago by timmywil

#8828 is a duplicate of this ticket.

comment:3 Changed 8 years ago by gnarf

Resolution: duplicate
Status: openclosed

comment:4 Changed 8 years ago by gnarf

Duplicate of #6641.

Note: See TracTickets for help on using tickets.