Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9461 closed bug (duplicate)

removeData not working for names with a "-"

Reported by: sieber@… Owned by:
Priority: high Milestone: 1.next
Component: data Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

When using names containg a "-" character in the data's name the removeData function does not work. Here some steps to reproduce:

var $b = $('body'); $b.data('x-y', 1); console.log($b.data('x-y')); ok, this shows a 1 $b.removeData('x-y'); console.log( $b.data('x-y') ); not ok, this shows still a 1, should show undefined

Change History (2)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfileddata
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Rick Waldron

Duplicate of #7328.

Note: See TracTickets for help on using tickets.