Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#9428 closed bug (duplicate)

Changing href attribute value in IE 7+ also changes link text (innerHTML value)

Reported by: agtlewis Owned by:
Priority: low Milestone: 1.next
Component: attributes Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

<script type="text/javascript">
jQuery(document).ready(function(){
    jQuery(function() {
        jQuery("#articleBody a:not(.notrack)").attr("href", function(i, attr) {
            return 'http://domain.com/track_click.php?bid=13&pid=5037&destination=' + escape(attr);
        });
    });
});
</script>

<div id="articleBody" class="entry">
<p>Please contact me 555-1212 or by email at <a href="mailto:[email protected]" target="_blank">[email protected]</a></p>
</div>

Expected output:

<p>Please contact me 555-1212 or by email at <a href="http://domain.com/track_click.php?bid=13&amp;pid=5037&amp;destination=mailto%[email protected]" target="_blank">[email protected]</a></p>

Actual output:

<p>Please contact me 555-1212 or by email at <a href="http://domain.com/track_click.php?bid=13&amp;pid=5037&amp;destination=mailto%[email protected]" target="_blank">http://domain.com/track_click.php?bid=13&amp;pid=5037&amp;destination=mailto%[email protected]</a></p>

Change History (4)

comment:1 Changed 11 years ago by agtlewis

Forgot to add in the summary that this only applies to mailto links. The code already posted will demonstrate the problem when tested on certain IE versions. I am getting reports of this happening with IE 7, and I confirmed it happens with IE 8.

comment:2 Changed 11 years ago by [email protected]

This has been reported and rejected as wontfix at least twice (not counting this ticket).

comment:3 Changed 11 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

actually patchwelcome

comment:4 Changed 11 years ago by timmywil

Duplicate of #8805.

Note: See TracTickets for help on using tickets.