Bug Tracker

Opened 15 years ago

Closed 15 years ago

#942 closed bug (worksforme)

jQuery.unbind(element,"eventtype") not working in IE7

Reported by: [email protected] Owned by:
Priority: major Milestone: 1.1.2
Component: event Version: 1.1.1
Keywords: unbind Cc:
Blocked by: Blocking:

Description

Using a debugger, I stepped through the code, and found the problem is here:

for ( var i in element.events[type] ) delete element.events[type][i];

In this specific case, the type was "mouseover", and there was only one event of that type. Rather than stepping through that code, it was completely skipped over. When I ran the command:

delete element.events[type];

This removed the event. So perhaps there is some problem with the javascript enumerator when there is only one element in a collection? Not sure.

Change History (4)

comment:1 Changed 15 years ago by john

Version: 1.1.1

Would it be possible to provide a more-complete example of this occurring? Does this error also occur in IE6?

comment:2 Changed 15 years ago by brandon

I am unable to reproduce this. Could you provide a test case?

comment:3 Changed 15 years ago by jeffkretz

I can only assume that I had something wrong in my original project, because I can't reproduce this error either. Perhaps I was running some additional script that conflicted with the jQuery event model.

This should be closed, sorry 'bout that. JK

comment:4 Changed 15 years ago by brandon

Resolution: worksforme
Status: newclosed

Glad it got worked out. Feel free to reopen the ticket if you are able to reproduce the issue.

Note: See TracTickets for help on using tickets.