Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#94 closed bug (invalid)

XPath issue

Reported by: john Owned by:
Priority: major Milestone: 1.0
Component: core Version: 1.0
Keywords: Cc:
Blocked by: Blocking:

Description

In firebug console (or in page JS):

$("td")

[<td>,<td valign="top">,<td>]

$("td/input")

a has no properties

using svn revision 159

Can anyone confirm?

Change History (2)

comment:1 Changed 14 years ago by anonymous

How odd, I can't reproduce it at http://cbwhiz.com/programming/js/bug94/bug94.html (simplified testcase) but I can reproduce it at http://liua.org/main.php (using firebug to test)

I know the latter isn't anywhere near valid html (I blame the designer...) but I still don't understand why it fails.

comment:2 Changed 14 years ago by john

Resolution: invalid
Status: newclosed

The fact that this isn't duplicable in a contained setting is rather suspicious. I'd definitely check to see if there are un-closed tags.

Regardless, it is a weird bug, but until we have a way to reproduce it, I'm going to close the ticket.

Note: See TracTickets for help on using tickets.