Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9380 closed bug (duplicate)

className returns invalid attribute classname

Reported by: uipoet Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Before jQuery 1.6,

jQuery('<span/>', { className: 'foo' };

would return: <span class="foo"/>

Since jQuery 1.6, this returns: <span classname="foo"/>, which is invalid.

Change History (3)

comment:2 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Use the class attribute name, not the className property.

comment:3 Changed 9 years ago by dmethvin

Duplicate of #9150.

Note: See TracTickets for help on using tickets.