Bug Tracker

Opened 9 years ago

Closed 9 years ago

#9369 closed bug (invalid)

jqXHR object can't handle binary data on IE, and raw XHR object not available

Reported by: alex@… Owned by: alex@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I am passing binary data through XHR, setting the content type to x-user-defined.

Firefox and IE have different behavior when it comes to putting binary data in string. Firefox doesn't mind, IE does mind.

In jquery before 1.5, as a hack, you can use the IE-only responseBody parameter to get the raw data out before converting it to what it needs to be.

However, the new jqXHR object in 1.5 abstracts that all away, leaving no way to get the response data out.

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Component: unfiledajax
Owner: set to alex@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket! Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.