Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#9362 closed bug (fixed)

.attr("value") does not work for meter elements

Reported by: aaron.grunthal@… Owned by:
Priority: low Milestone: 1.6.2
Component: attributes Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

After updating to jquery 1.6.1 (from 1.4.something) i noticed my html5-shim for meter elements was broken. It seems that $("meter").attr("value") returns undefined, despite the attribute node being present in the DOM while $("meter").attr("min") works just fine to get the minimum.

I assume this breaks because jquery tries to be "clever" in its handling of input elements. But this is not an input element.

jQ should probably check if the value property is actually present before it tries to redirect the attribute lookup to it.

Change History (7)

comment:1 Changed 6 years ago by anonymous

Nevermind. I tried the git version and the issue seems to be fixed there.

comment:2 Changed 6 years ago by rwaldron

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 6 years ago by rwaldron

Duplicate of #9319.

comment:4 Changed 6 years ago by rwaldron

  • Component changed from unfiled to attributes
  • Priority changed from undecided to low

comment:5 Changed 6 years ago by timmywil

  • Milestone changed from 1.next to 1.6.2
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Different problem than the val issue, but this was fixed in commit 25118e22a204c5396f1265feb5cbfd71f35033e3

comment:6 Changed 6 years ago by timmywil

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:7 Changed 6 years ago by rwaldron

@timmywil - Thanks for the clarification

Note: See TracTickets for help on using tickets.