Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#936 closed bug (fixed)

Rework xmlhttp usage to poll object instead of attaching onreadystatechange handler

Reported by: mikael.karon@… Owned by:
Priority: minor Milestone:
Component: ajax Version:
Keywords: Cc:
Blocked by: Blocking:

Description

As we all know the IE GC is at best a-royal-piece-of-garbage (pun intended), especially when it comes to closures and event handling. By attaching javascript to an ActiveX object (any DOM element and the XMLHttpRequest object) and then referring to the object itself one runs the risk of fcking the GC.

There are several tricks that prevent (or lessen the effects) this by variable reassigning and so on, but why not circumvent that entirely? Alex Russell (Dojo fame) posted a little about it at http://alex.dojotoolkit.org/?p=528 and I think it makes sense. By observing the request rather then trying to rig it one can escape the death trap known as the IE GC.

Attachments (2)

patch.txt (5.6 KB) - added by mikael.karon@… 13 years ago.
Suggested patch for XMLHTTP inspection rather then rigging
patch.2.txt (5.6 KB) - added by mikael.karon@… 13 years ago.
Suggested patch for XMLHTTP inspection rather then rigging

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by mikael.karon@…

Attachment: patch.txt added

Suggested patch for XMLHTTP inspection rather then rigging

Changed 13 years ago by mikael.karon@…

Attachment: patch.2.txt added

Suggested patch for XMLHTTP inspection rather then rigging

comment:1 Changed 13 years ago by mikael.karon

forgot to mention that this is against [1295]

comment:3 Changed 13 years ago by choan

This is a (previous) duplicate of #991, already fixed.

comment:4 Changed 13 years ago by john

need: Review
Resolution: fixed
Status: newclosed
Type: enhancementbug
Version: 1.1
Note: See TracTickets for help on using tickets.