Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9352 closed bug (invalid)

Internet Explorer aborts first AJAX request

Reported by: Tekin Owned by: Tekin
Priority: low Milestone: 1.next
Component: ajax Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have this small code

$.getJSON('/ajax.php',{
		mode: 'submitBlogEntry',
		entry: $('#formular').serialize()
	},
	function(data){
		if (data.message == 'reload') {
			pageReload();
		}
		else
			  showMessage(data.message, data.caption, 'small', 'notify');
	}
);

A simple post for our blog. When I submit this request with Internet Explorer (tested with IE 8) the request is sent to the server but IE aborts the JS of jQuery. Doing a second submit without reloading the page the request is sent and IE waits for the respond to react properly.

I tried to add random data and changed the request to POST without getting any better result.

Change History (5)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledajax
Owner: set to Tekin
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket!

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by Tekin

Status: pendingnew

Where can I get the jQuery (edge) version? Do you mean the actual version?

Also I need to read the documentation of jsFiddle before I can use it :) So it will take a short while I guess. :)

comment:3 Changed 8 years ago by dmethvin

Status: newpending

Hi Tekin, take a look at most of the other tickets to get an idea of how to use jsfiddle.

http://bugs.jquery.com/timeline?daysback=2

In jsFiddle you can select "jQuery (edge)" as the version to use.

comment:4 Changed 8 years ago by Tekin

Status: pendingnew

Thanks dmethvin. I tested it on jFiddle. You can close this case as "invalid" because as far as I can see it is an odd behaviour of IE.

My form has no action but the JS for submission is started with an input type=button. It seems that IE sometimes submits the formular (to be exact in the fist time I click on Save) and sometimes not (the second time I click again).

I changed the input tags to anchors and now it works like it should.

comment:5 Changed 8 years ago by Rick Waldron

Resolution: invalid
Status: newclosed

per OP request

Note: See TracTickets for help on using tickets.